How to Integrate to Rapid7 InsightVM?

  • 21 September 2021
  • 3 replies

Userlevel 1

I am trying to setup the AVM inside Cymulate.  Below you will see what I have done thus far...

I have gone into Cymulate’s Integration and Selected Edit on the InsightVM Integration Module and my email & password auto-filled.  Https://###.###.###.###:3780/  is the IP address format that I inputted  from my On-Prem InsightVM’s Console.

I have one agent depolyed.  I logged into My VPN on this device for it to find this system on the Domain. I still was not successful in connecting the VM back to Cymulate’s AVM.

What can I do to get this API connection resolved?



Best answer by Cymulate_CharlesRoberts 22 September 2021, 17:59

View original

3 replies

Userlevel 1
Badge +1

@Jason_Sumner was able to get this figured out.


“We (Admins) have our logins set to Platform.  I created a NEW User with the login only to InsightVM and not logging into the Platform setting turned off.  This allowed me to connect in Integrations.”



September 21, 2021. 02:24:46 PM: Authenticate (60) - Nexpose result: Connected? False, Error: Common.Comm.HTTPS.Exceptions.RestApiCallException: Failed to make API call for: InsightVMApi

---> System.Net.Http.HttpRequestException: Response status code does not indicate success: 401 (Unauthorized).

   at System.Net.Http.HttpResponseMessage.EnsureSuccessStatusCode()


Hope this helps other members of the community in the future!


Thanks Jason!


-Charles Roberts

Hi All,


This answer is not clear to me. I’m having the same issue, do you mind elaborating on that a bit more?. Which special role this NEW user should have?. It might be worth giving some screenshots of the nexpose config.


Thanks a lot !


Userlevel 1
Badge +1

@Eduardo_Paramo I will reach out to @Jason_Sumner and see if he can provide any additional information in this regard.


-Charles Roberts